Umlaute werden nicht angezeigt!


 
Reply to this topicStart new topicStart Poll





Straßenmusiker/in
***

Gruppe: 4FANS-Mitglieder
Mitglied seit: 09. Nov 2009
Beiträge: 158
16. Feb 2010, 21:23
Link · · · · Zitat
Seit ungefähr einer Woche bin ich von Cutenews zu Wordpress (jedoch benutze ich Wordpress nur als News Management) gewechselt und jetzt habe ich ein Problem mit den Umlauten. Auf der Startseite d.h. http://leighton.4fans.net/ kann ich im Content keine Umlaute schreiben, da sonst so etwas herauskommt: "Â" oder "ü". Wenn man allerdings dann auf "Keine Kommentare" oder auf "Ältere Einträge" klickt, ist das Problem nicht mehr im Content sondern in der Sidebar.

Hoffe mir kann jemand helfen, da es mit der Zeit echt schon nervig geworden ist mit den ganzen Umlauten mit ae & co zu schreiben smile.gif.





4FANS-Team
*********

Gruppe: 4FANS-Admins
Mitglied seit: 10. Oct 2004
Beiträge: 9392
16. Feb 2010, 23:59
Link · · · · Zitat
Schau mal in die Adresszeile. Wenn man die Seite aufruft dann steht dort http://leighton.4fans.net, wenn man auf Kommentare klickt, dann steht dort auf einmal http://leighton.4fans.net/wordpress/.

Du hast somit zwei ganz verschiede Seiten, einmal komplett über Wordpress und einmal ohne wo du den header & footer und Wordpress "includest". Sowas machen nur Leute die Wordpres nur als News verwenden wollen was eigentlich nicht richtig ist, besser man nutzt dann Wordpress ganz als eine Art "kleines CMS".

Jedenfalls liegt das Problem an den Zeichensätzen, ich habe im WordPress Admin (bzw. Wordpress-Datenbank) den Zeichensatz (blog_charset) geändert und dort "latin1" eingetragen. In der wp-config.php habe ich dann noch unter DB_CHARSET den Zeichencode gelöscht, so dass es nun so aussieht: define('DB_CHARSET', '');

Nun wird alles wieder richtig angezeigt. smile.gif





Straßenmusiker/in
***

Gruppe: 4FANS-Mitglieder
Mitglied seit: 09. Nov 2009
Beiträge: 158
17. Feb 2010, 01:40
Link · · · · Zitat
Wow, danke Dennis! Du bist der beste hug.gif !





Clubsänger/in
****

Gruppe: 4FANS-Mitglieder
Mitglied seit: 04. Oct 2009
Beiträge: 384
05. Aug 2013, 09:26
Link · · · · Zitat
Ich habe auch ein Problem mit den Umlauten!
Bei mir ist es aber leider auf der ganzen Seite so und hab schon im Forum geschaut aber nichts gefunden was geholfen hat.

Hat jemand vllt noch eine Lösung für mich?


--------------------





4FANS-Team
*********

Gruppe: 4FANS-Admins
Mitglied seit: 10. Oct 2004
Beiträge: 9392
05. Aug 2013, 14:46
Link · · · · Zitat
In dem 2. Post steht die Lösung, es gibt insgesamt 3 Werte die man ändern kann, eins in der Datenbank, zwei in der Config-Datei. Stelle es so ein wie beschrieben.

Je nachdem wie man die Seite aufgebaut hat kann es aber auch vorkommen dass man es nicht hinbekommt, dann müsste man die Umlaute im WordPress-Theme gegen HTML-Zeichencodes ersetzen. Probiere es aber erst mal oder schick mir ein Link wenn es eine 4fans.net-Seite ist, helfe gerne.





4FANS-Team
****

Gruppe: 4FANS-Jury
Mitglied seit: 03. Feb 2011
Beiträge: 370
05. Aug 2013, 16:20
Link · · · · Zitat
QUOTE (Dennis @ 05. Aug 2013, 14:46)
... gegen HTML-Zeichencodes ersetzen ...

Das Problem habe ich auch und schaue dafür immer mal auf selfhtml.org vorbei smile.gif


--------------------
.:: jenniferlawrence.de ::. ~ deine erste deutsche Fanpage rund um Jennifer Lawrence!





Clubsänger/in
****

Gruppe: 4FANS-Mitglieder
Mitglied seit: 04. Oct 2009
Beiträge: 384
06. Aug 2013, 14:10
Link · · · · Zitat
QUOTE (Dennis @ 16. Feb 2010, 23:59)
Jedenfalls liegt das Problem an den Zeichensätzen, ich habe im WordPress Admin (bzw. Wordpress-Datenbank) den Zeichensatz (blog_charset) geändert und dort "latin1" eingetragen. In der wp-config.php habe ich dann noch unter DB_CHARSET den Zeichencode gelöscht, so dass es nun so aussieht: define('DB_CHARSET', '');

Also ich habe jetzt in der wp-config.php das so stehe:
('DB_CHARSET', 'utf8');

Also müsste es dann so sein:
('DB_CHARSET', '');


So, die zweite Frage wäre dann, wo finde ich dieses:
(blog_charset)


--------------------





Clubsänger/in
****

Gruppe: 4FANS-Mitglieder
Mitglied seit: 04. Oct 2009
Beiträge: 384
11. Aug 2013, 11:09
Link · · · · Zitat
QUOTE (Dennis @ 16. Feb 2010, 23:59)
Jedenfalls liegt das Problem an den Zeichensätzen, ich habe im WordPress Admin (bzw. Wordpress-Datenbank) den Zeichensatz (blog_charset) geändert und dort "latin1" eingetragen.

Ok, ich habe jetzt alles soweit gemacht! Meine Frage ist nun, wo ich das genau finde ich weiß jetzt gerade wirklich nicht wo ich da schauen muss!


--------------------





4FANS-Team
*********

Gruppe: 4FANS-Admins
Mitglied seit: 10. Oct 2004
Beiträge: 9392
11. Aug 2013, 11:14
Link · · · · Zitat
Man muss sich bei phpMyAdmin einloggen (Link gibt es im Kundenmenü), in die Wordpress "options" Tabelle gehen und dort mal durchblättern. Dort steht dann irgendwo "blog_charset".





Clubsänger/in
****

Gruppe: 4FANS-Mitglieder
Mitglied seit: 04. Oct 2009
Beiträge: 384
11. Aug 2013, 11:28
Link · · · · Zitat
Ah ja ok, vielen Lieben Dank, hat gut geklappt!


--------------------



Thema wird von 1 Benutzer(n) gelesen (0 Mitglieder, 1 Gäste und 0 Anonyme Benutzer)
 


Reply to this topic Start new topicStart Poll